Having problems with your 2003 Mercury Mountaineer ?

Trouble codes again on my 2003 Mercury Mountaineer.

\015 Have already replaced two 02 sensers on my 2003 Mercury Mountaineer.Bank 1 senser 1 and Bank 2 senser 1.Both had codes and needed replaced.Days have gone by and today got two codes PO133 and PO 153.Both sensers slow to respond whatever that means,And now I'm hearing a noise that kind of sounds like a HOWLING noise though the exhaust and when that happens the idle increases a couple hundred RPM and then returns to normal.I'm at a loss as to what may be causing this.Thanks in advance for any help that can be given on this problem.\015 Posted / edited by AnonymousUser on : 14-09-2020

Answers :

Hi! The problem could be on the MAF (mass air flow) sesor. If the MAF is faulty the idle goes crazy and can make the engine stutter. The MAF has big contribution on engine performance specially on the idling. Once replaced you'll be good and please write back on how it gone. Hope this helps and have a good one!
Repair Help & Product Troubleshooting for 2003 Mercury Mountaineer

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0079 seconds