Having problems with your 2003 Mercury Mountaineer ?

My 2003 mercury mountaineer ABS light is staying on. manually, the brakes work however they shimmy.changed the brake pads,checked the brake fluid and ABS fuse,bud when changing the pads,did now clean the wheel sensors.could this be the problem with out a diagnstic tool to checl?

Posted / edited by AnonymousUser on : 24-09-2018

Answers :

I replaced the hub bearing assembly on drivers side twice and the light stayed on and the brakes worked fine. It was the wires (visible just above the tire on the frame) that rubbed against the frame that had shorted out. It was simply repaired and clip-stripped up out of the way. The light has been off every since then.
Sounds like a bad hub/bearing assembly. It houses the abs sensor. I had the same problem. Replaced the bad hub/bearing assembly and no more shimmy. with a bad hub/bearing assembly the wheel will wobble all over the road
Repair Help & Product Troubleshooting for 2003 Mercury Mountaineer

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0088 seconds