Having problems with your 2003 Pontiac Sunfire ?

I have a 2001 sunfire. 2.2, automatic. Over 1 month ago the car began running hot. I had the water pump replaced, then the radiator. The car still ran hot and I am not lossing any fluid. 5 days ago the head gasket was replaced and now to this day the car still runs hot. What else could it be? I appreciate any input that you can give my mechanic and I. Thank You, Judy

Posted / edited by AnonymousUser on : 10-12-2018

Answers :

Well there is a few things it could be.
\015\012 1) is the electric fan turning on? If not then it could be the fan motor, a break in the wires, the fuse or the relay switch.
\015\012 2) check the actual coolant temp. If it doesn't match your temp gadge then it could be the gadge or the temp sensor.
\015\012 3) air pockets in the cooling system(Block)
\015\012 4) incorrect coolant mixture
This could be your oil cooler check your water and see if there is any traces of oil in the water even if there aren't I cant see it being anything else because of what you have already had replaced,Ihope this is of some help to you.
Repair Help & Product Troubleshooting for 2003 Pontiac Sunfire

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0082 seconds