Having problems with your 2004 Mercedes-Benz C-Class ?

Windscreen (windshield) washer does not work but wipers work fine

\015 Mercedes c320 se coupe 2004 (model ref W203) - when you press the button at the end of the stick attached to the steering whell column there is no water spray, no washer pump noise and the wipers do not initiate.\015\012\015\012The wipers on their own work fine at the 3 different speeds. \015\012\015\012At first thought it was a fuse but there aren't any fuses specified in the handbook's fuse list (just says electronic instead of giving a fuse rating). Already replaced the washer pump with a brand new one - makes no difference.\015\012\015\012Unless there is a cut in the wire, or the push stick button is broken all we can think of is a possible relay malfunction.\015\012\015\012Does anyone know the relay layout or indeed know what the fault could be (if not the relay).?\015 Posted / edited by AnonymousUser on : 13-01-2020

Answers :

This could be anything in between. Heres where I would start. DOES the vehicle spray water in any other speed? Do all speeds work?
\015\012If all speeds work fine the problem could be in the SENSOR controlling the actual Spray pump. NOT worth fixing. OR your wires going to the spray pump could be cut! Check the resistance real quick between the pump and the sensor. It also may be the culprit.
Repair Help & Product Troubleshooting for 2004 Mercedes-Benz C-Class

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0087 seconds