Having problems with your 2005 Audi A4 ?

A4 high beams stay on

\015 After the interior got pretty wet due to a super hard rainstorm (I had left the sunroof popped up, and each of two front door windows abt 1" shy of closed), the highbeam indicator on the dash lit up, "all by itself," as I was driving home. Even after turning the engine off and removing the keys, the high beams remained on. Obviously I could not leave it in this state overnight. I know the location of the electrical connectors to the headlamp assemblies, so I actually unplugged them. Seems less burdensome than disconnecting and reconnecting the battery, considering all the steps entailed as part of the reconnect. Even after accomplishing that, the blue high-beam indicator remains lit on the instrument panel. I am thinking that something got damp and now a faulty bit is set somewhere in the lighting control circuitry. Will this correct itself once the car has thoroughly dried out? I'll know by this time tomorrow.\012\012Will post again when this is resolved.\015 Posted / edited by AnonymousUser on : 25-05-2020

Answers :

Repair Help & Product Troubleshooting for 2005 Audi A4

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0087 seconds