Having problems with your 2005 Ford Expedition ?

Help fix my truck please

\015 Our truck went into failsafe mode. Changed the fuel filter and unhooked battery then it ran fine for a whole day. Next day did the same thing... Stalling has no acceleration power and doesn't idle right. We changed the throttle body but it is still acting the same way.\015 Posted / edited by AnonymousUser on : 14-01-2019

Answers :

Several things come to mind. Usually failsafe has something to do with overheating or a temperature sensor falsely thinking the engine is overheating.
Another problem is a part called a "Cam Phaser". It would account for stalling, no power, no acceleration and not idling right. It is not an electronic part. Do an internet search for the part and read the results.
Because the "cam phaser" is not electrical, it is not directly identified by the onboard computer. The effects of the malfunction could possibly have other electrical parts trigger the "fail safe". As for part of the problem temporarily leaving after the battery was disconnected, it is common when power is removed.
Briefly, the cam phaser mechanically advances cam timing, but each side of the engine has its own phaser. Problems result when both phasers do not work equally.

Please rate my info.
Repair Help & Product Troubleshooting for 2005 Ford Expedition

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0053 seconds