Having problems with your 2005 Nissan Altima ?

I am helping my daughter with her 2005 Altima 2.5 They were driving it on the highway and the check engine light came on, started missing, loss of power. It was smoking white (not like a burning type of smoke but a vapor type). When at idle in gear engine shakes badly. When they got home (drove for 1 hour that way)I pulled codes, I have a scanner. It came back with bank 1 02 sensor 2. And engine lean code. We changed out the downstream 02 sensor. I cleared the codes and they drove the car to se

Posted / edited by AnonymousUser on : 15-10-2018

Answers :

First thing you can do to eliminate a possible cause is trade the coil packs between 1&4, and 2&3. Check again and if 1&4 are now dead, then you replace the bad coil pack.

You stated that the plugs were wet, but didn't say from what. What did the plugs smell like? Oil, fuel, or coolant?

Please let me know what was on those plugs, as there could be other causes as well.
Repair Help & Product Troubleshooting for 2005 Nissan Altima

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0097 seconds