Having problems with your 2005 Nissan Xterra ?

When my 2005 Xterra S is at idle there is a mild knocking sound coming from the back left side (as i look at it) of the engine along with (while operating) vehicle shaking like its about to die out but once i start to accelerate it's fine. This happens only at idle. It was worse right before i changed oil (10-30W), oil filter, spark plugs (NGK), didn't change the Air Filter yet and it's still doing same thing with Service engine light on.

Posted / edited by AnonymousUser on : 17-06-2019

Answers :

Not sure if you've found the solution..You need to 1) Ck the side engine mounts for cracks,you can plainly see if they are..If so replace them.2) Have the target idle bumped up 50 to 75 rpm's.It'll take care of your problem
I would get ur computer system scanned to see if ur misfire or code is even referring to anything in the left rear of engine,if it does u could have some internal damage,maybe under left rear valve cover, possibly worn valvetrain parts????
Repair Help & Product Troubleshooting for 2005 Nissan Xterra

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0096 seconds