Having problems with your 2007 GMC Acadia SLE ?

I smelled smoke and lost my instrumentation

\015 As I was driving down the road, I smelled smoke in my 2007 Acadia, to which I attributed to an outside source. I arrived at my destination with no problem. However, when I restarted my engine and had driven a short distance, I realized that I had no instrumentation (speedo, tach, fuel, etc.). My dash panel lights were all working along with all other electrical. Just before arriving at my destination, I once again smelled the same smoke smell. I shut the engine off and let it set for an hour. I couldn't find anything wrong under the hood. I restarted the engine and all of my instumentation was functional again. There was no other problem during the ten mile drive back home. I suspect a short in a harness or a module problem. Any suggestions?\015 Posted / edited by AnonymousUser on : 12-11-2018

Answers :

Go to this site and ck for any electrical recalls. EWspecially in reference to cruise controls
\015\012
\015\012http://www-odi.nhtsa.dot.gov/cars/problems/recalls/results.cfm
Repair Help & Product Troubleshooting for 2007 GMC Acadia SLE

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0086 seconds