Having problems with your 2009 Toyota Tacoma ?

Check engine light & Slip indicator light on together why?

Posted / edited by AnonymousUser on : 11-01-2021

Answers :

Both the Check Engine light and the Slip Indicator light on my 2009 Tacoma came on for no apparent reason. The truck has only 34,000 miles on it. After reading blogs on the internet by people having the same problem with their Tacoma, I tried the easiest potential fix first: just tighten the gas cap until it "clicks" and disconnect the positive cable from the battery for about 20 minutes. Bingo, that fixed the problem! Those simple actions saved me a trip to the Toyota dealer and who knows how much in charges by their service department.
Had the check engine & VSC lights come on. Did not notice any different behaviour of my 2009 Pre-Runner.
Read in one 'fix' to disconnect the battery for 15 - 20 minutes and restart. But first I went to Toyota and with a 'smile' they said that will be 1 1/2 hours and $130.00!
OK - so I politely excused myself and brought the truck home. Figured I'd try the discnnect the battery fix first, then take it to my mechanic. VIOLA!! This appears to have done the trick when the truck was restarted, it went out. Also for the sake of - reset the gas cap and took the opportunity to do a little battery maintenance.

Trust this helps, but is not the 'fix-all' for anything beyond the system just didn't re-set itself properly!
Repair Help & Product Troubleshooting for 2009 Toyota Tacoma

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0079 seconds