Having problems with your Cars & Trucks ?

I have a 1994 buick park avenue, one day the car just wouldnt start and the security light came on. After three minutes the security light would go off and the car would start up. After few days, it would have the same problem but it would take anywhere from three minutes to an hour to get it started. We tried jumping it and that worked too. Now we have replaced the wire harness in the steering column, but the car will not start at all, and the security light flashes. Can anyone help? Itsbeen

Posted / edited by AnonymousUser on : 19-02-2018

Answers :

I believe your car has a passkey security system,a chip in the key is actually a resistor which sends a signal to a module allowing the car to start.There are two very small wires running from the ignition (perhaps purple and white) which relay this signal it sounds like one of these may have become broken or disconnected,they should run down column and out under the right side make sure these are connected, if they are you may have to replace the key or the module as the vehicle will turn over but not start.Hope this helps.
Repair Help & Product Troubleshooting for Cars & Trucks

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0088 seconds