Having problems with your BMW 525 ?

Bmw altenator I have a 2000 BMW 328ci with 220,000 km on it to date. When I start the car on cold mornings the car starts with power... it is not weak when I turn the key...(not a battery problem) however the car revs and then shakes on its own... the lights also flicker... at over 1 RPM... once it almost gets warm ...about 3 to 5 mins... my car then shuts off. I then start it again and the temperature gauge shows that the car is at a normal temp and the car then runs smoothly and drives beautif

Posted / edited by AnonymousUser on : 16-07-2018

Answers :

Sounds like a bad battery connection check for bad loose corroded terminals at the battery and check at opposite end which you may have to crawl under the car for that make certain if you have disconnected any ground wires located throughout the car that you put them back and from my experience I have seen them do allot of strange things as to the running of a vehicle when removed and not put back.dont try to check altenator by pulling off one of the batt cables that worked in the old days but can produce voltage spikes nowadays which can destroy many of the electronics used in the running of your vehicle
Repair Help & Product Troubleshooting for BMW 525

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0057 seconds