Having problems with your Buick Century ?

MY Buick Century that I purchased sat for like 3 years without been driven. I did a tune up which consisted of oil change, and plug change. I did not change out my wires and change the coil pack(3).. My car has started to run rough and sound like it is sick. What are some solutions. Could this be coilpack and wires.??

Posted / edited by AnonymousUser on : 18-01-2021

Answers :

With the vehicle having set for three years without having been driven, running rough or rough idle could be anything. Did you inspect the spark plug wires thoroughly to make sure there were not damaged? Did you drain the old gas and replace it with new? Are are you getting a check engine light? There are some simple steps to test the coil pack and here's an easy one
I would say its a fuel problem. You can try replacing the fuel filter, but there may be foreign matter in the tank and in the injectors.
Repair Help & Product Troubleshooting for Buick Century

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0087 seconds