Having problems with your 2000 Ford Expedition ?

Hi guys: I have 2000 Ford Expedition 5.4 4WD XLT. Since few months my baby has some problem to run specially when up a hill and she dont wants to go. I did research about that code and found that information on internet. 1. Faulty spark plug or wire 2. Faulty coil (pack) 3. Faulty oxygen sensor(s) 4. Faulty fuel injector 5. Burned exhaust valve 6. Faulty catalytic converter(s) 7. Running out of fuel 8. Poor compression 9. Defective computer First I save some money and went to the mecha

Posted / edited by AnonymousUser on : 03-08-2020

Answers :

Okay, when you changed the Number 2 plug, did you also change the wire? Have you checked the Injector seat for a leak? Do this by spraying Choke cleaner on it while engine is running to see affect on RPM.
\012
\012Check for Intake gasket for leaks. Clean the MAF sensor with safe Electric cleaner. If still no help, on some Fords there was a groove under the Airhorn gasket that needed periodic cleaning. Its 8 bolts and a $10 gasket.
\012
\012Put on a pressure gauge at Injector rail and see if fuel pressure drops on acceleration. You can do a cylinder balance test Electronically and see if compression is a problem. Code 302 is a misfire on the #2 cylinder.
\012
\012Would like to know outcome and if this is the DOHC engine with Cam Phasers.
Repair Help & Product Troubleshooting for 2000 Ford Expedition

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0056 seconds