Having problems with your Chevrolet 1500 ?

I have a Ford F-150, 2001, 6 cylinder. The problem is, ever since, I had my fuel pump replaced the gas gauge doesn't work properly, reads only to 1/4 of a tank, and the check engine came on. I have had my oxygen sensor replace twice now, but the engine light comes on a few days after. I hope someone can tell me what could be the problem. Thank you, BB

Posted / edited by AnonymousUser on : 03-08-2020

Answers :

Sounds like when the pump was replaced the fuel gauge float on the pump got stuck when the pump was put back into tank.With the check engine lamp did you have some one check ecm for a code,there are many things that can set a code not just a oxygen sensor.
Your fuel level sensor is on the side of your fuel pump inside the gas tank. The pump will need to be removed and the sensor straightened out... Since excess fuel is pumped back into the tank from the fuel pressure regulator, (as well as emission return and vacuum) they probably messed something up there as well and gave you emission errors.
Repair Help & Product Troubleshooting for Chevrolet 1500

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0100 seconds