Having problems with your Chevrolet Chevy ?

2003 s-10 will not shift to lower gear automaticly. changed filter and fluid, worked fine for a few mintues and then stopped. think it may be a speed sensor but do not know what it looks like.

Posted / edited by AnonymousUser on : 19-10-2020

Answers :

If your trans will not go into lower gear, it is probably defaulted to 2nd gear. Have the system scanned. You probably have a sensor or solenoid that is bad. I am assuming that since you changed the fluid, you would have noticed if there was a lot of friction and or metal in the pan. If the pan was really bad, then you need to get the trans overhauled. I have been rebuilding these 4l60e trans since they came out in the original model 700R4 in 1982. They are a pretty good trans, but if there is metal or friction, nothing short of the overhaul will fix it.
\015\012
\015\012If your speedo is working, you do not need a speed sensor, however if the speedo is not working, then start there, In an 03 it is on the tail housing of the trans with a two prong plug, or if is a 4X4 it is on the transfer case tail. (If by chance it is not there, some models use the sensor on top of the rear differential for the speed sensor. I just don't quite remember what year they changed.
\015\012
\015\012Hope this helps.
Repair Help & Product Troubleshooting for Chevrolet Chevy

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0055 seconds