Having problems with your Chevrolet S 10 ?

1996 s10, 4.3, started getting hard to start in the morning, to the point of needing a jump. Battery was fully charged but it seemed to need that extra boost to start. Battery new, starter new, coil new alternator new, fuel regulator new, spider near new, fuel pump near new, motor sensors new, plugs new, dist cap new, rotor new, wires new, now won't start even with a boost. Spark related, plenty of fuel. Possible related symptom, awhile back it started acting like it might be missing a beat goin

Posted / edited by AnonymousUser on : 15-04-2019

Answers :

You didn`t mention a check engine light.But even if the light has not come on check for codes.The code for the crank shaft position sensor is a po338 and will not illuminate the check engine light.This can cause a hard start,no start,slow start,backfire,or kick back.The crank shaft position sensor is on the timing cover on the bottom end.There is a service bulletin for this.The number is 00-06-04-014.Give this a try.Hope this helps.Good luck.
Repair Help & Product Troubleshooting for Chevrolet S 10

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0060 seconds