Having problems with your Chevrolet Silverado ?

305 bottom end 350 heads headers holly intke an 600cmf carb will run an idle at 8 degrees advanced but really runs good at about 30 degrees advanced.ive put a light on it an my mark is about an inch away from any degree mark. did they put the wrong damper on it? my vacum advance on my dist. touches my intake. but it runs good there thank you

Posted / edited by AnonymousUser on : 26-10-2020

Answers :

It sounds like the timing is off you need to put the crank at top dead center and the crank mark should be at zero pull the number one plug and make sure the piston is all the way up pull valve cover on the number one cover and see if the valves are loose, if they are not your timing chain is off by two teeth. To fix you will have to pull the timing cover off and point the teeth at each other the one on the bottom should be straight up and the one on top straight down. if you have air you can apply air to the #1 plug slightly if it leaks out then you can be sure the timing chain is off. once the timing chain is set at TDC zero then pull out the distributor and turn the rotor to #1 plug you may have to move the rotor gear two teeth you should be able to turn it both directions equally.
Something is wrong if its an inch away from 8 degrees If the engine shakes or vibrates more than it should get the correct damper
Repair Help & Product Troubleshooting for Chevrolet Silverado

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0103 seconds