Having problems with your Chrysler Neon ?

Hi, Can i ask for a final clarity on the 'limp in' mode please. I have a 2001 2.0L SE auto. The SES light is on, I replaced the TCM. I still get P0700. The car is fairly smooth into reverse and drive, but is stuck in 2nd. It will drive smoothly up to 40-45 but I haven't taken it any further. There is no power loss, the speedometer works, all lights work ok, radio is fine and no other codes flash up. Removing the battery to reset the module has not worked. The answers are this so far. 1. R

Posted / edited by AnonymousUser on : 17-06-2019

Answers :

Make sure the battery is fully charged and giving 12V Minimum with key out of ignition - if the battery is slighlty weak it can interfere with the workings of the computer and bring up irrelevant codes.\015\012
\015\012After you know the power is good AND the problem still exists then have the codes scanned or you're working blind.\015\012
\015\012If the fluid is more than 2 years old replace it anyway
\015\012
I have the same problem and I was told to take it back to the dealer and let them know that I got the P0700 code. They then have to reprogram the computer if they were able to if not they would haved to change the whole computer.
Repair Help & Product Troubleshooting for Chrysler Neon

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0060 seconds