Having problems with your Dodge Avenger ?

I have a 1995 Dodge Avenger ES that has been sitting for several months. The battery was dead so I took it out and charged it. I put it back in the car and the car started right up. I let the car run for a few minutes and then shut it off. I cleaned up the car a bit and went to start it again and it wouldn't start. In fact the dash lights went on then the car went dead. Now I have absolutely no power.

Posted / edited by AnonymousUser on : 19-02-2018

Answers :

It would appear that your batteries integrity has been lost. Make sure both your connections are clean and put a meter across the battery while it is running. If it shows a charge 13-14 volts then your battery is at fault, if the meter reads 12volts or less than your alternator or the drivebelt is at fault. Fuses and relays are very rarely the cause of a non charging situation. Thank you, Dana
Hello. Chances are that your battery is actually no good. Take the battery out and into any auto parts store where they can test the battery and it's ability to hold a charge. You will probably be purchasing a new one. Regards, Joe
Repair Help & Product Troubleshooting for Dodge Avenger

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0057 seconds