Having problems with your Dodge Dakota ?

2002 dakota, i had the whole dash out to fix the condensate line. Now i have a "no bus" signal on the odometer and only the oil pressure gauge registers slightly. I have a hard time believing i missed a connection. All the pins on the gauge cluster are good and all gauges will zero themselves when u plug them in. Also a code scanner will read all parameters and i have a 5v reference at the tps. Hope you can help

Posted / edited by AnonymousUser on : 18-06-2018

Answers :

Has to be the dash not earthing properly to the mountings,,loose connections are most lickely
Sounds like you either missed a reconnection on a plug or a plug didn't get seated. Or one may have come loosed while moving the dash around. I suggest pulling the dash panel loose enough to recheck all the connections. Also you may have simply blown a fuse. check your owner's manual and it'll tell you which is the fuse for the instrument cluster. pull the fuse to inspect, replace as needed.
Repair Help & Product Troubleshooting for Dodge Dakota

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0058 seconds