Having problems with your Ford Escape ?

I have a ford Escape 05 and it seems to be running rough I just got the alternator changed including new spark plugs but I find there is a loud grinding noise and idles rough when under load. I've noticed that when I first start it is sounds pretty rough as well. do you have an idea what it could be

Posted / edited by AnonymousUser on : 23-04-2018

Answers :

I'am only going to quess here.
\015\012The spark plugs have no bearing on anything.
\015\012The alternator is usually a remanufactured item. That said, you don't always get new bearings in the case. I wouldn't suspect they are the noise, you hear though.
\015\012IF, you didn't have these issues before the alternator switch, You, know where the current problem is.
\015\012Meaning,either the new alternator has the wrong pulley on it,and the belt is not tracking correctly,thus putting pressure on the sides of the tension and idler pulleys. Now you have a real mess,noise and belt about to chew it's self apart.
\015\012Second,if I'am wrong,remember,I am quessing, then you have other problems,not properly addressed, for some reason,when they relieved you of some money for the alternator isses.
Repair Help & Product Troubleshooting for Ford Escape

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0048 seconds