Having problems with your Ford Taurus ?

Have a 1996 Taurus wagon--dead battery--got brand new battery and connected it properly and car barely turns over and wont turn enough to start--car was sitting for about three months

Posted / edited by AnonymousUser on : 15-04-2019

Answers :

Was the battery checked before it was sold to you? Batteries will lose their charge over a period of time even when not hooked up. If you have a voltmeter it should read 12.8 volts on a fully charged battery.
Have you tried to boost the car with cables?
I suspect if the car was working OK 3 months ago it should start. Which leads me to suggest an undercharged battery.
Try a boost off another running car with a good pair of booster cables....or put a battery charger on it for a few hours at around 10 amps .....then try it.
The new battery may not have been fully charged when purchased.
It would measure around 12.6 volts if it is fully charged.
Repair Help & Product Troubleshooting for Ford Taurus

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0093 seconds