Having problems with your Honda Civic ?

Hi my name is john ,i own a 115 hp vro evinrude outboard and i have a problem with it when i go full throttle after about 5 to 10 minutes it dies.after some checking i found i had no spark at the ht leads and very little cranking power either.after about 10 minutes i had power again .but i did notice all my guages where reading wrong .eg temp guage follows the engine revs volt guage reads 18 volts .but i checked it with a multimeter and it was 13.7 volts constant and now she idels rough altough

Posted / edited by AnonymousUser on : 15-04-2019

Answers :

Check the wiring harness for any smashed areas. sounds like you have wires touching each other. Also check around the computer for corrosion. this will cause the same problem. If there is corrosion on the outside, there is probably some on the inside to. you can clean pc boards wih a soft brass bristle brush. Just don't clean to much! Also check and clean any wires you find that are corroded.
Repair Help & Product Troubleshooting for Honda Civic

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0059 seconds