Having problems with your Mazda 626 ?

I have telstar tx5 ghia 1990 2,2l 4 cilind automatic, power everithing,car is done 240000.yus wont start one mornig doing klik didn t start and couple time kliking alnaser (starter) and i have used cable to try start with other car, but no start,batery is ok.I have turned pulley motor is ok ,wasn't hard to turn, im thinking sometig wrong with power .Now there is no power in cabin ,nothing .power come on door lights an when I tried to turn key,no contact light ,power gone and nothing . nothing

Posted / edited by AnonymousUser on : 19-02-2018

Answers :

Hi
\015\012Easiest test is to reconnect jumper cables and switch lights on, if these work and no noise AT ALL from starter, NO clicking at all then could be the jumper cables are too light like most are. Try 2 sets of jumper cables. Ensure that the cables are correclty applied, Red to Red and the black is the last connection to a good steel part on your engine, NOT the battery.Always ensure the car being used to jump from is running at all times while cables are connected.When it starts remove this one FIRST also.
\015\012
\015\012Cheers cbacer
Repair Help & Product Troubleshooting for Mazda 626

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0119 seconds