Having problems with your Mercedes-Benz 420-Series ?

While driving, the A/c blows nice and cold. When in slow traffic or at idle (stopped at a light) it does not work as well. The freon is full. Any suggestions?

Posted / edited by AnonymousUser on : 23-04-2018

Answers :

This is a symptom of a low refrigerant charge, u have a leak, the most common cause of leaks on your car is the AC compressor shaft seal, adding a can of stop leak may cure this for awhile, to do this add about 8 oz's of the recommended refrigerant (u don't say year) to your system at the low side charging port, that is in the larger of the two lines coming from the AC compressor. Buy a recharge kit, it comes with instructions on how to install the refrigerant and know when the system is full, Kragen and other stores like Autozone carry these kits, they are about $25.00
You possibly have a vacuum leak...\015\012\011\011\015\012\015\012Vacuum leak is usually under the battery or right at the intake manifold. I've had leaks at both places.
Repair Help & Product Troubleshooting for Mercedes-Benz 420-Series

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0052 seconds