Having problems with your Mitsubishi Eclipse ?

I have a 2003 mitsubishi eclipse and have never had any problems getting up to 130 mph+. I just recently got my car back from the shop after replacing the thermostat, doing a coolant flush, and replacing my air filter. Prior to taking it in my temperature gauge would move up and down sparratically, but even with this problem my car still had power and could accelerate quickly. After getting it back from the shop though it struggles to get up over 80 mph and when i tryi to accelerate quickly it m

Posted / edited by AnonymousUser on : 11-11-2019

Answers :

Only a hunch but the more i read this question the more iam stuck ,Now iam not sure about this remove the iar intake and try it again ,no because it has an air flow meter ??see what an old dinasaur i am ,now this noise i have come across before a few times but mainly on diesels ,where the driver has tried to start vehicle on a cold morning with a lighted rag and the engine has sucked rag it ??Best advice i can give at the moment to to remove air intake and have a look also between the air filter box and the inlet manifold in case the mechanic has run engine with air filter off to give access to something and a mouse or something has got into engine now this i have seen before now as well .Also please keep speed down to 80kph .conserve fuel so the troops can come out of iraq and ragheads can drink crude
Repair Help & Product Troubleshooting for Mitsubishi Eclipse

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0095 seconds