Having problems with your Nissan 240SX ?

Hello i have a 1993 nissan 240 sx with 160,000 on it i replace the timing chain and nock baring too. Now when I start the engine and hit the gas pedal it sound like if I put cheap gas on it and if I turn the ac on and I stop in traffic the temperature gage goes hi.

Posted / edited by AnonymousUser on : 11-11-2019

Answers :

Your timing chain was not set correctly. Click on the link below and follow the picture diagrams to correctly set the timing marks. Because it is off, your vehicle is running sluggish and overheating the engine
\015\012
\015\012http://www.justanswer.com/questions/1wypu-how-do-i-set-a-timing-chain-on-a-nisson-240sx
It sounds like to me the chain was installed on the gears ok BUT it is one tooth off alignment. This will make the engine run like you state upon starting and causing the temp gauge to rise as you say. I am surprised you did not mention any popping noises made neither from this. One question for you. Did you by chance reeplace the plug wires recently after replacing the timing parts? If so check the wire routing for two wires can be installed incorrectly too causing this delimma
Repair Help & Product Troubleshooting for Nissan 240SX

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0094 seconds