Having problems with your Nissan Maxima ?

I have nissan patrol 2001 automatic with a mileage of 124,567... the problem is when my speed is at 80 to 90km my rpm is about 3000 to 4000, also sometimes my speed is at 50km to 60km my rpm is 3000 to 4000 revolution also...suddenly i feel its weak power....this happens when im using the car after 3 hours of running..... also when im in a reverse mode.... and the car is going to a elevated position the car doesnt moved even if i step hardly on the acclerator ...the power is too low and it cant

Posted / edited by AnonymousUser on : 16-09-2019

Answers :

Transmission is failing the reverse gear has proved it. This is why the reverse is second gear in a automatic transmission that why at times if it can get pass second it can accelerate and go fast if it cant get past second then it slips as you drive, your second gear in this transmission is failed if you need to prove to yourself that the transmission has failed look at the transmission fluid my friend it is blackish or black it is burnt, leave the turbo out of the picture there is nothing wrong with it. as for the injection pump a ck engine light will appear and the code will be a lean bank EGI failure. leave the pump out there is nothing wrong with it. you transmission look at the fluid it burnt transmisssion has failed and is slipping
Repair Help & Product Troubleshooting for Nissan Maxima

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0059 seconds