Having problems with your Oldsmobile Aurora ?

I repaced my catalytic converter on my car. It was clogged, and drove it longer than I should have. It has been replaced, but my car still will not pull up hills and idles rough at low RPMS. We have changed all of the spark plugs too. The idle controler on the engine is making a sputtering or popping sound too. could this need changed or someone suggested an EGR valve. What could be causing the loss of power now?

Posted / edited by AnonymousUser on : 21-06-2021

Answers :

Hi, not sure what car or engine you have but I would agree with both. If the IAC is popping, it probably isn't working right or the passage is clogged. If your exhaust was clogged, the EGR may also be clogged ot the valve possibly broken. Take it off and check to see if it closes properly. Remove the IAC valve and clean out the air passages. Put it all back together and see how it does. If these actions don't solve the issues, please get back to me with model, year, and engine.
Repair Help & Product Troubleshooting for Oldsmobile Aurora

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0087 seconds