Having problems with your Volvo S60 ?

The top torque rod broke and i replaced it,now i have a wissel and a engine light is on i know the engine twisted pretty hard before i changed the torque rod mount am i missing something??

Posted / edited by AnonymousUser on : 19-04-2021

Answers :

It sounds like maybe a sensor plug was pulled loose or a wiring harness damaged by the engine movement, what u need to do at this point is have the electronic engine control system tested for the system fault code(s) that is stored whenever the check engine light is turned on, this system is called the OBD2 electronic control system, u can either buy a code reader any auto parts or get one on ebay, cost about $40 USD, also if u have any Kragen or Autozone parts stores near u they will run the test for free in most area's, call and see what the policy is, this test is not avail in California. Once u have the code you can examine the sensor for wiring damage, but until u have the fault code u will not know where to look, there are allot of parts that set codes and turn on the light.
Repair Help & Product Troubleshooting for Volvo S60

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0098 seconds